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What Is File Defender ?
File Defender is a versatile tool you can use to protect and monitor your system.

File Defender can:

- Detect the presence of viruses by verifying file checksum.
- Detect the presence of viruses without the need of updating.
- Track down corrupted files caused by system failures (power interruptions, inadvertent 

reboots and resets, etc.)
- Be configured to run automatically.
- Be configured to run in background mode.
- Monitor a single file or entire disk.

File Defender consists of the three programs:

The File Defender Workfile Manager (FD.EXE) provides all of the commands which 
allow build, edit, open, save File Defender Workfiles and File Defender Errorfiles, as well 
as provide a launching platform for the companion program FDefend.

FDefend (FDEFEND.EXE) is the utility program that performs all of the protection 
functions (checksums, etc.) on File Defender Workfiles, as well as create File Defender 
Errorfiles.

The FD Scheduler (FDSCHED.EXE) is a versatile scheduling utility used to launch 
FDefend at a specified time completely unattended.    The schedulers versatility allows it 
to be used with any Windows program or non-Windows application and can be configured
to run programs by certain intervals, on certain days or one time only. For help using FD 
Scheduler see FD Scheduler's help system (FDSCHED.HLP)

Using these three programs together you can effectively protect and monitor your system 
against the disastrous effects of viruses, power interruptions, inadvertent reboots and 
resets, etc.

To learn how to use File Defender to protect and monitor your system see File Defender 
Strategies

File Defender makes use of standard Windows elements such as sizable windows, dialog 
boxes, 
scroll bars, and buttons.    If you are not familiar with these items, consult your Microsoft 
Windows 
documentation or the Program Manager's help system.

File Defender has both mouse and keyboard support, as well as context sensitive help



File Defender Strategies
For help on File Defender strategies, choose one of the following tasks: 

Detecting viruses
Tracking down corrupted files



Virus Detection 
A computer virus is a program designed to replicate and spread on its own, preferably 
without the user knowing that it exists.    The effects of viruses vary. Sometimes they go 
unnoticed, sometimes your system will display strange messages, or sometimes entire disks
are wiped clean!

There are various types of viruses:

1 Viruses that attach themselves to an executable file's code.    Every time the program 
runs, the virus spreads itself to other executable files.

2 Viruses that attach themselves to the boot sector of a computer's hard or floppy disk. 
Every time the computer is started, the virus loads itself in to memory and can 
spread to other disks.

3 Viruses that are disguised as legitimate programs.    Every time the bogus program 
runs, the computer is infected and/or is damaged by the virus.

To reduce your chance of attack from a virus and to lessen the casualties if one does occur, 
use File Defender 1.00.

The basic procedure for using File Defender to detect viruses is as follows.

Select Files

1 From the File Defender Main Window , using the mouse or menu commands to select 
the files you want FDefend to scan for viruses..(See Building Workfiles)

2 Save your selected files in a File Defender Workfile.(See Opening and Saving 
Workfiles)

Important: Before selecting files it should be stressed that only virus free files be 
selected.    If there is any doubt about the integrity of your system reload any 
files that you deem suspect.

Run FDefend Regularly

1 From the File Defender Main Window, open the FDe  fend Configuration   Dialog Box 
to configure FDefend. (SeeConfiguring FDefend)

2 Run FDefend or schedule FDefend (using    FD Scheduler) to run regularly to scan your
system for possible corrupted files due to viruses. (SeeRunning FDefend)

Check for Errors

1 From the File Defender Main Window, open the File Defender Log.(SeeOpening the
File Defender Log)

2 Examine the contents of the Log starting with the most recent entry to determine if 
any viruses were detected.(SeeExamining the File Defender Log)

Replace Damaged Files

1 In the event you find an entry where the ERRORS= field is non-zero, from the File 
Defender Main Window open the File Defender Errorfile in the corresponding 
ERRORFILE= field.(SeeOpening File Defender Errorfiles)

2 Examine each entry in the Errorfile examine the FILENAME, ERROR TYPE, OLD 
VALUE and NEW VALUE fields to determine the appropriate action to take.



(SeeExamining File Defender Errorfiles)
3 Replace any corrupted files and/or update the Workfile as necessary.(SeeUpdating 

Workfiles)



Tracking down corrupted files
A file may be corrupted by sources other than the deliberate corruption from viruses.    These
include:

 - Unexpected power failures.
 - Improperly working disk cache programs.
 - Conflicting programs accessing the disk.
 - Operating Systems failures causing the machine to hang.

The most common victims are open data files at the time of the incident. which means you 
should backup you data files frequently minimizing the amount of data lost. Program files 
(executables) are equally susceptible to these effects, but are less likely to fall prey to 
corruption because they often are open long enough to read into memory and then be 
executed.
You may have seen the MS-DOS Chkdsk command (CHKDSK /F) print the message:

x lost allocation units found in y chains.
Convert lost chains to files?

If you answer Y files with the extension '.CHK' appear on the current directory. These files 
are indication that corruption of some type has occurred but does not tell you where it has 
happened. Many times they may be temporary files used by various programs during 
execution and will have no adverse effect. Frequently they are a part of a data file use by a 
program. Less frequently they are actual program code indicating a corrupted program.

For example:

You have just had a power failure. You were working on a document with one of the popular 
word processors. 'WORDPRO.EXE' for illustration purposes. When the system comes back 
up, you run CHKDSK /F and it reports:

13 lost allocation units found in 2 chains.
Convert lost chains to files?

You answer Y. Now what? You run your program 'WORDPRO.EXE' hoping no harm has come
from the incident. The machine locks up. Oh NO!    While this may have never have 
happened to you. It has happened to many others.    This is what prompted the writing of 
File Defender 1.00. 

If you have an accurate File Defender Workfile with your program and initialization files and 
a failure occurred, you would be able to tell what files the fault corrupted. For example, you 
reboot and run File Defender and it reports that 'WORDPRO.EXE' has a checksum error. 
You would reload the word processor keeping your personal settings (File Defender did not 
find an error there) and then continue with your work. When you know where (or not where) 
the problem exists it becomes much easier to correct the problem. 

When things are not working right, File Defender can be an invaluable tool for tracking 
down where the fault lies.

The basic procedure for using File Defender to track down corrupted files is as follows.

Select Files

1 From the File Defender Main Window , using the mouse or menu commands to select 
the files you want FDefend protect against corruption.(SeeBuilding Workfiles)

2 Save your selected files in a File Defender Workfile.(SeeOpening and Saving 
WorkFiles)



Run FDefend Regularly

1 From the File Defender Main Window, open the FDe  fend Configuration dialog box   
to configure FDefend. (SeeConfiguring FDefend)

2 Run FDefend or schedule FDefend (using    FD Scheduler) to run regularly to scan your
system for possible corrupted files. (SeeRunning FDefend)

Check for Errors

1 From the File Defender Main Window, open the File Defender Log.(SeeOpening the
File Defender Log)

2 Examine the contents of the Log starting with the most recent entry to determine if 
any checksum errors were detected.(SeeExamining the File Defender Log)

Replace Damaged Files

1 In the event you find an entry where the ERRORS= field is non-zero, from the File 
Defender Main Window open the File Defender Errorfile in the corresponding 
ERRORFILE= field.(SeeOpening File Defender Errofiles)

2 Examine each entry in the Errorfile examine the FILENAME, ERROR TYPE, OLD 
VALUE and NEW VALUE fields to determine the appropriate action to take.
(SeeExamining File Defender Errorfiles)

3 Replace any corrupted files and/or update the Workfile as necessary.(SeeUpdating 
Workfiles)



Moving Around in File Defender
For help on moving around in File Defender, choose one of the following tasks: 

Changing Case
Changing Views
Changing Directories
Changing Drives
Displaying File Properties
Displaying a Group of Files
Displaying Subdirectories in the Directory Tree
Sorting Files
Updating the Directory Window 



Working with File Defender Workfiles
For help on working with File Defender Workfiles, choose one of the following tasks: 

Building Workfiles
Opening and Saving Workfiles
Updating Workfiles



Running FDefend
For help on running FDefend choose one of the following tasks: 

Starting FDefend
Running FDefend Using Menu Commands
Running FDefend Automatically
Configuring FDefend
Exiting Windows While FDefend is Running



Working with the File Defender Log and Errorfiles
For help on working with the File Defender Log and Errorfiles, choose one of the following 
tasks: 

Opening the File Defender Log
Examining the File Defender Log
Opening File Defender Errofiles
Examining File Defender Errorfiles



Ordering File Defender
File Defender is currently being marketed as shareware.    If you register the program you'll 
receive these remarkable benefits:

- The latest version of File Defender.
- An end to the nag screens and reminders.
- Limited free technical support by phone.
- Greatly reduced prices on upgrades.

Registration is $25.00 (CDN funds).

Call us for quantity pricing.

Order Form



(Select File|Print Topic to print this order form.)

Company: _______________________________________________________________
Name: _______________________________________________________________
Address: _______________________________________________________________

_______________________________________________________________
City:  _____________________ State/Prov.:_______ Zip: _______________
Phone: (______)__________________      Country:______________________________

Please send me (check desired items or enter number):

___ One license to use File Defender $25.00

___ One license to use File Defender, with disk $30.00
                Format:      [_] 3.5"              [_] 5.25"

___ (enter #) licenses to use File Defender @ $25 each $____

___ (enter #) licenses to use File Defender, w/disks @ $30 each $____
                Format:      [_] 3.5"              [_] 5.25"

Shipping & handling:    N/S America    free

Outside the Western Hemisphere    $5.00 ______________

Total      $______

Enclose a check or money order (payable to B&S Graphical Computer Systems) 

B&S Graphical Computer Systems 1-(902)-443-0374
P.O. Box 25053
Halifax, Nova Scotia    B3M 4H4

Compuserve ID: 71533,1272

Call us for quantity pricing.

I acquired File Defender from: 

Comments and/or suggestions:





Windows Keys

The keyboard topics below come from Help for Windows and are those topics relevant to File 
Defender.

Dialog Box Keys
Help Keys
Menu Keys
System Keys
Window Keys



Dialog Box Keys

Key(s) Function

TAB Moves from field to field (left to right and top to bottom).
SHIFT+TAB Moves from field to field in reverse order.
ALT+letter Moves to the option or group whose underlined letter matches 

the one you type.
DIRECTION key Moves from option to option within a group of options.
ENTER Executes a command button.

Or, chooses the selected item in a list box and executes the 
command.

ESC Closes a dialog box without completing the command. (Same as
Cancel)

ALT+DOWN ARROW Opens a drop-down list box.
ALT+UP or DOWN ARROW Selects item in a drop-down list box.
SPACEBAR Cancels a selection in a list box.

Selects or clears a check box.
CTRL+SLASH Selects all the items in a list box.
CTRL+BACKSLASH Cancels all selections except the current selection.
SHIFT+ DIRECTION key Extends selection in a text box.
SHIFT+ HOME Extends selection to first character in a text box.
SHIFT+ END Extends selection to last character in a text box



Help Keys

Key(s) Function

F1 Gets Help and displays the Help Index for the application. If the 
Help window is already open, pressing F1 displays the "Using 
Windows Help" topics.
In some Windows applications, pressing F1 displays a Help topic
on the selected command, dialog box option, or system 
message.

SHIFT+F1 Changes the pointer so you can get Help on a specific 
command, screen region, or key. You can then choose a 
command, click the screen region, or press a key or key 
combination you want to know more about.
(This feature is not available in all Windows applications.)



Menu Keys

Key(s) Function

Alt Selects the first menu on the menu bar.
Letter key Chooses the menu, or menu item, whose underlined letter 

matches the one you type.
Alt+letter key Pulls down the menu whose underlined letter matches the one 

you type.
LEFT or RIGHT ARROW Moves among menus.
UP or DOWN ARROW Moves among menu items.
Enter Chooses the selected menu item.



System Keys

The following keys can be used from any window, regardless of the application you are 
using.

Key(s) Function

Ctrl+Esc Switches to the Task List.
Alt+Esc Switches to the next application window or minimized icon, 

including full-screen programs.
Alt+TAB Switches to the next application window, restoring applications 

that are running as icons.
Alt+PrtSc Copies the entire screen to Clipboard.
Ctrl+F4 Closes the active window.
F1 Gets Help and displays the Help Index for the application. (See 

Help Keys)



Window Keys

Key(s) Function

ALT+SPACEBAR Opens the Control menu for an application window.
ALT+Hyphen Opens the Control menu for a document window.
Alt+F4 Closes a window.
Alt+Esc Switches to the next application window or minimized icon, 

including full-screen programs.
Alt+TAB Switches to the next application window, restoring applications 

that are running as icons.
Alt+ENTER Switches a non-Windows application between running in a 

window and running full screen.
DIRECTION key Moves a window when you have chosen Move from the Control 

menu.
Or, changes the size of a window when you have chosen Size 
from the Control menu.





File Defender Procedures
The procedures topics give you step-by-step instructions for using File Defender.

To learn to use help, press F1 or choose Using Help from the Help menu.

Moving Around in File Defender 

Changing Case
Changing Views
Changing Directories
Changing Drives
Displaying File Properties
Displaying a Group of Files
Displaying Subdirectories in the Directory Tree
Sorting Files
Updating the Directory Window 

Working with File Defender Workfiles

Building Workfiles
Opening and Saving Workfiles
Updating Workfiles

Running FDefend

Starting FDefend
Running FDefend Using Menu Commands
Running FDefend Automatically
Configuring FDefend
Exiting Windows While FDefend is Running

Working with File Defender Errorfiles

Opening the File Defender Log
Examining the File Defender Log
Opening File Defender Errofiles
Examining File Defender Errorfiles



Changing Directories

You can display the contents of a different directory by changing directories in the directory 
tree. If the directory you want is a subdirectory and does not appear in the directory tree, 
you can expand the directory so that you can see subdirectories. 

To change directories 
Click on a directory name in the directory tree window of the File Defender Main 
Window. 



Changing Case

You can change the case that File Defender uses to display the names of your files and 
directories. Changing the case affects both windows of the File Defender Main Window. 

To change the case
From the Options menu, choose the Lowercase command



Changing Views
When you first start File Defender, the left half of the directory window shows the directory 
tree, and the right half shows the names of all the files in the current directory. You can 
choose to display only the directory tree or only the directory contents. 

To display only the directory tree
From the View menu, choose the Tree Only command 

To display only the directory contents
From the View menu, choose the Directory Only command



Changing Drives

If you want to display the contents of a different disk, you can change drives in the directory 
window of the File Defender Main Window 

To change drives 
Click on a drive icon from the header bar.



Sorting Files

By default, files are listed alphabetically by name in the File Window of the File Defender 
Main Window. You can choose to display files alphabetically by their extension, by size (from 
smallest to largest), or by date, with the least recently modified file listed first. 

To sort files
1 From the View menu, choose the Sort By command to display the Sort By 

cascading menu.
2 From the Sort By cascading menu, choose one of    the following commands:

 Name Sorts files alphabetically by name. 
    Type Sorts files alphabetically by extension. 
        Size Sorts files from smallest to largest 
      Date Sorts files from youngest to oldest using last modification date. 



Displaying a Group of Files
You can display a group of files in the current directory, such as files with a certain extension
or of a particular file type. 

To display a group of files
1 From the View menu, choose the By File Type... command The By File Type dialog 

box appears 
2 Inside the dialog box, specify which files you want to display in the directory window 

of the File Defender Main Window. 
3 Choose the OK button. 



Displaying Subdirectories in the Directory Tree

To display subdirectories 
Click the icon of the directory you want to expand. 

To hide subdirectories
Click the directory icon you want to collapse. 

Note: You cannot collapse a directory if one of its subdirectories is displayed in the File 
Window of the File Defender Main Window, you must first make the directory you 
want to collapse the displayed directory.

Note:    Directories that have subdirectories are marked with a plus sign (+). After you 
expand a directory, it is marked with a minus sign (-). 



Updating the Directory Window
You may want to update the directory window if you've connected to a network drive outside
of File Defender. 

To update the directory window 
From the Window menu, choose the Refresh command



Displaying File Properties
You can use File Defender to display file information, such as icon, file size, last modification 
date, last modification time, and file attributes in the directory window of the File Defender 
Main Window. By default, only the names of files and directories are displayed. 

To display specific file information
1 From the View menu, choose the File Details... command.

The File Details dialog box appears.
2 Inside the dialog box, specify which information you want to display. 
3 Choose the OK button. 



Building Workfiles

Before you can use FDefend to protect your files, you must first select files to build a File 
Defender Workfile. There are several ways to select files in File Defender. If the files you 
want are visible in the File Window of the File Defender Main Window, you can use the 
mouse to quickly select them.    If the files are not visible, or if you want to select a group of 
files with similar names, use the Select Files... command in the File menu. 

Tip: While dynamic files, like a data base file, are not good candidates for File Defender, 
your programs and initialization files(such as WIN.INI) are.    It is therefore 
recommended to build    Workfiles that contains executable or system files. 
To do this, 
1 Use the By File Type... command from the View menu to display the By File 

Type dialog box
2 In the Filename display box,    entering only those extensions you want to select.
3 Click the OK button to close the dialog box.
4 Double click on the directory name to select all of the files displayed. 

Or, use the Select Files... command from the File menu to display the Select 
Files status box to quickly select files in the current directory and subdirectories.

Important: In order for File Defender to be effective, the files you select must be free from 
viruses.    If there is any doubt about the integrity of your system then it is advised
that you re-install any files that you feel may be infected before you select them.

For help building Workfiles choose one of the following tasks:

Using the Select Files... Command to Select/Deselect Files
Using a Mouse to Select/Deselect Files



Opening and Saving File Defender Workfiles
To open a File Defender Workfile 
1 From the File menu, choose the Open... command. The File Open dialog box 

appears
2 Inside the dialog box select the File Defender Workfile you want to open.
3 Click the OK button.

Note: Opening a previously saved File Defender Workfile causes all currently selected files 
to be lost, therefore File Defender automatically prompts you if you want to save the 
current Workfile.

To save a new File Defender Workfile 
1 From the File menu, choose the Save As... command. The File Save As dialog box 

appears
2 Inside the dialog box enter the filename for the File Defender Workfile you want to 

save.
3 Click the OK button.

To save a previously saved File Defender Workfile 
From the File menu, choose the Save command



Updating File Defender Workfiles
Updating File Defender Workfiles is required when you want to add or delete files to a 
currently existing Workfile.

Note: It is recommended that you update the files included in a Workfile if one of the 
following situations occur:

- Files have been added to you system.
- Files have been moved from one location to another.
- Files have been removed from your system.

To add files to an existing Workfile
1 From the File menu, choose the Open... command. The File Open Dialog Box 

appears
2 Inside the dialog box, select the Workfile you want to update.
3 Click the OK button.
4 Inside the directory window of File Defender Main Window, select the directory name 

of the of the files you want to add to the Workfile.
5 Inside the File Window of the File Defender Main Window, select the files you want

to add to your Workfile.
6 From the File menu, choose the Save command to save the updated Worklist.

To remove files from an existing Workfile
1 From the File menu, choose the Open... command. The File Open Dialog Box 

appears
2 Inside the dialog box, select the Workfile you want to update.
3 Click the OK button.
4 Inside the directory window of File Defender Main Window, select the directory 

name of the of the files you want to add to the Workfile.
5 Inside the File Window of the File Defender Main Window, deselect the files you 

want to add to your Workfile.
6 From the File menu, choose the Save command to save the updated Worklist.



Using a Mouse to Select/Deselect Files
You can use a mouse to select a file or group of files. Before you can select files, they must 
be visible in the directory window of the File Defender Main Window. 

To select a single file using the mouse
Click on a filename to select that file.

To deselect a single file using the mouse
Press Ctrl and click on a filename to deselect that file.

To select a group of files using the mouse
1 Click on the first file you want to select.
2. Press Shift and click on the last file in the group you want to select.

Note: To add\remove one file to\from a group selection, press Ctrl while clicking. 

To select all the files in a directory using the mouse
Double-click on the directory name.

To deselect all the files in a directory using the mouse
Double-click on the directory name.



Using the Select Files... command to Select/Deselect Files
Use the Select Files... command to quickly select/deselect files in the directory window of 
the File Defender Main Window

To select files by using the Select Files... command
1 From the File menu, choose Select Files... command. The Select Files status box 

appears.
2 Inside the dialog box, type the names of the files you want to select.
3 Click the Select button.

To deselect files by using the Select Files... command
1 From the File menu, choose Select Files... command.The Select Files status box 

appears.
2 Inside the dialog box, type the names of the files you want to deselect.
3 Click the Deselect button.



Starting FDefend
FDefend can be started from Program Manager,    File Manager, or any other Windows shell 
program.    

To start an FDefend from Windows File Manager
Double-click the program file (FDEFEND.EXE) in the File Defender directory. 
Or select the program file, and then choose Open from the File menu (or press 
ENTER). 

To start an FDefend from Windows Program Manager
Double-click the FDefend icon from the File Defender program group. 
Or select the program file, and then choose Open from the File menu (or press 
ENTER). 

To start an FDefend and open a Workfile from Windows File Manager
Drag a Workfile icon to the program file (FDEFEND.EXE)    in the File Defender 
directory.

To start an FDefend and open a Workfile from Windows File Manager
1 Select the    FDefend icon from the File Defender program group. 
2 From the File menu, choose Run. 
3 In the Run dialog box, specify the File Defender Workfile you want to open. 
4 Choose the OK button. 



Running FDefend Using Menu Commands
FDefend can be started from the File Defender Main Window by using commands from the 
FDefend menu.

To run an existing File Defender Workfile
1 From the FDefend menu, choose the Run File... command. The File Run dialog box 

appears
2 Inside the dialog box select the File Defender Workfile you want to run.
3 Click the OK button.

To run the current File Defender Workfile 
From the FDefend menu, choose the Run All command

Note: File Defender creates a temporary file called RUNALL.DAT when you choose the Run 
All command.



Running FDefend Automatically
In order for File Defender to be effective, it must be used periodically.    It is recommended 
that File Defender be used at least once each Windows session.    The simplest way to do this
is to run FDefend automatically.    One method is to run FDefend on Windows start-up, an 
alternative method is to schedule FDefend to run at specific times of the day or time 
intervals. 

To run FDefend automatically
1 Open your WIN.INI file(WIN.INI is located in your WINDOWS directory) using a text 

editor such as Notepad (NOTEPAD.EXE). 
2 Find the [windows] heading of the file. (it should be located near the beginning of 

the file.)
3 Find the run line.
4 To install:

Modify the run line are required.
Examples:
a. run=c:\fd\fdefend.exe
This would bring up a dialog box prompting the user for a File Defender Workfile 
name on Windows start-up.
b. run=c:\fd\fdsched.exe
where FDSCHED.EXE is the name of the File Defender scheduling program, FD 
Scheduler.
This example would run FDEFEND.EXE at a previously scheduled time as configured 
in the scheduler program. 
c. If you are using Windows 3.1 then FDSCHED.EXE or FDEFEND.EXE can be 
added to the Startup Group, and Windows will start these programs each time you 
start Windows.

Note: Use care when making changes to any initialization file such as WIN.INI. Incorrect 
changes can lead to unexpected results when you use Windows. Always back-up your
WIN.INI file before opening it!



Configuring FDefend
You can configure FDefend to run in one of two modes of operation; normal or background 
mode (hidden).    In each mode there are various options which let you specify the actions 
FDefend takes when it encounters errors.

To configure FDefend
1 From the FDefend menu, choose the Configuration... command. The FDefend 

Configuration Dialog Box appears
2 Inside the dialog box, configure FDefend as required.
3 Click the OK button.



Exiting Windows While FDefend is Running
If you attempt to exit Windows while FDefend is still running, FDefend will ask you if you 
want to terminate the program.

- If you choose Yes, FDefend will terminate and save any error that it has found.
- if you choose No, FDefend will continue running and Windows will not close.



Opening the File Defender Log
A summary of the results of running FDefend are recorded in File Defender Log.

To open the File Defender Log:
1 From the FDefend menu, choose the Log... command. The File Defender Log 

appears.
2 Examine the Log for possible problems.

----------------------------------------------
See also
Examining the File Defender Log



Examining the File Defender Log

 FDefend results are reported in the File Defender Log in the following manner;

Workfile - The name and path of the File Defender Workfile.
Status - One of :    Aborted, Completed, User terminated,    or Error.(See also 

FDefend Status)
Errors - The number of error found.
Errorfile - The name and path of the File Defender Errorfile (if saved).

The following is a typical File Defender Log with comments.    These comments do not appear
in the normal File Defender Log.    They have been added to give meaning to each entry of 
the log:

------------------------------------
LOG OF FDEFEND:

Each entry in the File Defender log begins with the date (yyyy/mm/dd) and time the 
entry was created.

1992\11\02    03:01:09 WORKFILE=c:\fd\programs.dat; STATUS=Completed; ERRORS=0; ERRORFILE=Not Saved
FDefend ran with the Workfile 'c:\fd\programs.dat'. No errors were found of any kind 
so no Errorfile was needed.

1992\11\03    16:36:40 WORKFILE=C:\FD\programs.dat; STATUS=User terminated; ERRORS=50; ERRORFILE=c:\fd\
programs.err

FDefend ran with the Workfile 'c:\fd\programs.dat'. The user terminated the program 
before completion.    50 errors were found and the results were save in the Errorfile 
'c:\fd\programs.err', an old copy of 'c:\fd\programs.err' may have been overwritten.
Action: Examine the Errorfile 'c:\fd\programs.err' to determine source of errors.

1992\11\04    21:31:40 WORKFILE=c:\fd\temp.dat;STATUS=Error
FDefend was attempted to run with the Workfile 'c:\fd\temp.dat'. FDefend was unable
to open the Workfile.
Action: From the File Defender Main Window try to open the Workfile 'c:\fd\temp.dat' 
to determine if it is a valid File Defender Workfile.

1992\11\05    03:43:03 STATUS=Aborted
FDefend was started with no Workfile.    A dialog box was displayed to prompt the 
user to select a Workfile to run.    The user aborted the program by choosing Cancel.

1992\11\06    01:15:29 WORKFILE=C:\FD\programs.dat; STATUS=Completed; ERRORS=34; ERRORFILE=c:\fd\
progr000.err

FDefend ran to completion with the Workfile 'c:\fd\programs.dat'. 34 errors were 
found and the results were save in the newly created Errorfile 'c:\fd\progr000.err'.
Action: Examine the Errorfile 'c:\fd\progr000.err' to determine source of the errors.

1992\11\07    16:36:40 WORKFILE=C:\FD\programs.dat; STATUS=User terminated; ERRORS=50; ERRORFILE=c:\fd\
progr001.err

FDefend ran with the Workfile 'c:\fd\programs.dat'. The user terminated the program 
before completion.    50 errors were found and the results were save in the newly 
created Errorfile 'c:\fd\progr001.err'.
Action: Examine the Errorfile 'c:\fd\progr001.err' to determine source of the errors.

1992\11\07    16:37:40 STATUS=Aborted, FDefend already running
FDefend attempted to run while FDefend was already running.
Action: If you are running FDefend using FD Scheduler you may have to reschedule 
FDefend to run with larger intervals.



1992\11\07    22:10:23 WORKFILE=c:\fd\programs.dat; STATUS=Completed but unable to save Errorfile; ERRORS=1
FDefend ran to completion with the Workfile 'c:\fd\programs.dat'. One error was found
and the results were not save.

------------------------------------

The File Defender log file is found in the File Defender home directory.

----------------------------------------------
See also
Examining File Defender Errorfiles



Opening File Defender Errorfiles
FDefend errors are recorded in File Defender Errorfiles.

To open File Defender Errorfiles:
1 From the FDefend menu, choose the Errorfile... command. The File Open dialog box

appears.
2 Inside the dialog box select the Errorfile you want to open.
3 Click the OK button.
4 Examine the Errorfile for possible viruses or corrupted files.

Note: The File Open dialog box does not list File Defender Errorfiles that FDefend has 
saved as hidden.    

----------------------------------------------
See also
Configuring FDefend
Examining File Defender Errorfiles



Examining File Defender Errorfiles
FDefend reports errors in the following manner;

Filename - Filename (and path) of the file in which an error was found.
Error Type - One of 4 error types; Checksum, Size, Date/Time, Attribute, or Not 

Found(See also FDefend Errors)
Old Value - Previous value
New Value - Current value 

The following is a typical File Defender Errorfile with comments.    These comments do not 
appear in a normal File Defender Errorfile.    They have been added to give meaning to each 
entry:

--------------------------------------------
1992-11-5
1:45:151:45:15

Each File Defender Errorfile begins with the date (yyyy/mm/dd) and time the entry file
was created.

RESULTS OF FDEFEND 1.00:

        FILENAME ERROR TYPE OLD VALUE NEW VALUE

1. C:\MSW\NOTEPAD.EXE CheckSum -2081598602 -623363915
Entry 1 indicates that the contents of the program ' C:\MSW\NOTEPAD.EXE' has been 
altered.

2. C:\FD\FD.EXE Attribute ---A HRS-
Entry 2 indicates that the file attributes of the program file 'C:\FD\FD.EXE' has 
changed.    In this case the archive bit has been cleared and the hidden, read-only 
and system bits have been cleared.          

3. C:\PROGRAMA.EXE CheckSum -2081598602 -623363915
Entry 3 indicates that the contents of the program ' C:\PROGRAMA.EXE' has been 
altered.

4. C:\PROGRAMA.EXE Size 110848 111872
Entry 4 indicates that the contents of the program ' C:\PROGRAMA.EXE' has been 
altered.
Action: Entries 3 and 4 indicate that the file 'C:\PROGRAMA.EXE' has been altered, if 
the reason for this change cannot be explained (update, etc) then it may be infected 
by a virus and hence should be replaced with a virus free copy.

5. C:\TEMP\~FDE029A.TMP CheckSum -995273418 -1600916023
Entry 5 indicates that the contents the file ' C:\TEMP\~FDE029A.TMP' has been 
altered.        

6. C:\TEMP\~FDE029A.TMP Size 73418 24423
Entry 6 indicates that the size the file ' C:\TEMP\~FDE029A.TMP' has changed from 
73,418 bytes to 24,423 bytes.        

7. C:\TEMP\~FDE029A.TMP Date\Time 1992-11- 5 1992-11- 5
23:18:54 23:28:24

Entry 7 indicates that the last time the file 'C:\TEMP\~FDE029A.TMP' was modified 
has been altered.
Action: Entries 5-7 indicate that the file 'C:\TEMP\~FDE029A.TMP' is a temporary file,
hence remove this file from the Worklist to prevent FDefend from generating 
unwanted errors.    



8. C:\PROGRAMB.EXE Not Found
Entry 8 indicates that the program 'C:\PROGRAMB.EXE' could not be found.
Action: If the file 'C:\PROGRAMB.EXE' does not exist remove it from the Worklist.

--------------------------------------------

File Defender Errorfiles are saved with the extension 'ERR'.

----------------------------------------------
See also
Updating Workfiles





File Defender Commands
This topics give you step-by-step instruction for using File Defender commands.

To learn to use help, press F1 or choose Using Help command from the Help menu.

Commands

File    FDefend    View    Options    Window    Help



File Menu

The File menu includes commands that enable you to open and save File Defender 
Workfiles, edit Workfiles, establish a new workspace, and to exit the program.

For more information, select a File menu command name.

                                                    New Alt+F,N Creates a new File Defender Workfile
                                                Open Alt+F,O Opens an existing File Defender Workfile
                                                  Save Alt+F,S Saves the active File Defender Workfile
                                      Save As Alt+F,A Saves and names the currently selected group of 

files as a File Defender Workfile
                        Select Files Alt+F,L Selects or deselects files in the directory window.
                                                        Exit Alt+F,X Quits File Defender.



FDefend Menu

The FDefend menu includes commands that enable you to run File Defender Workfiles., 
open the File Defender Log and File Defender Errorfiles, and configure how FDefend runs. 

For more information, select the FDefend menu command name.

        Run All Alt+D,U Runs FDefend using the currently selected files as the File 
Defender Workfile.

    Run File Alt+D,F Runs FDefend using an existing file as the File Defender 
Workfile.

                                                    Log... Alt+D,G Opens the File Defender Log.
                                  ErrorFile... Alt+D,E Opens an existing File Defender Errorfile.
                             Configure... Alt+D,C Configures FDefend.



View Menu

The View menu includes commands to modify the display and specify the information you 
want to display.

For more information, select the View menu command name.

    Tree and DirectoryAlt+D,R Displays both the directory tree and the contents of the 
current directory.

                                      Tree Only Alt+V,E Displays only the contents of the current 
directory. 

                      Directory Only Alt+V,D Displays only the directory tree.
                                File Details Alt+V,F Displays specific file information in the file 

window. 
                                                Sort By Alt+V,S File sort options. 
                            By File Type Alt+V,B Displays a group of files that you specify. 



Options Menu

The Options menu includes commands that enable you to specify options not associated 
with the File Defender File Window.

For more information, select the Options menu command name.

                                            Lower Case Alt+O,L Displays all files and directories in lower 
case.

        Save Settings on Exit Alt+O,S Saves View and Option Menu settings as when 
you last quit File Defender. 



Window Menu

The Window menu includes commands that enable operation on the File Defender Main 
Window.

For more information, select the Window menu command name.

Refresh Alt+W,R Updates the entire File Defender Main Window.



Sort By Cascading Menu

The Sort By cascading menu commands enable you to specify the order in which files 
appear in the    File Defender Main Window.

For more information, select the Sort By cascading menu command name.

                    Name Alt+V,S,N Sorts files alphabetically by name. 
                        Type Alt+V,S,T Sorts files alphabetically by extension.
                            Size Alt+V,S,S Sorts files from smallest to largest 
                          Date Alt+V,S,D Sorts files from youngest to oldest using last 

modification date. 



Help Menu

The Help menu includes commands associated with the help system plus addidional 
information not required to use the program.

For more information, select the Help menu command name.

                                                              Index Alt+H,I Displays the opening screen of Help
                                            Keyboard Alt+H,K Describes how to use the keyboard with File 

Defender 
                                      Commands Alt+H,C Shows an index of all the File Defender 

commands.
                                      Procedures Alt+H,P Shows an index of all the File Defender 

procedures.
                                        Using Help Alt+H,H Describes how to use Help.
                                                  Register Alt+H,R Register your copy of File Defender.
    About File Defender Alt+H,U Displays product name, copyright, credits, 

program version, registration, and useful system statistics.



New command (File menu)

Use this command to delete all selected files and open a new    File Defender Workfile .    

If the current Workfile has been saved, the new Workfile is opened immediately.

If the current Workfile hasn't been saved, a dialog opens to ask whether you want to save 
changes made to the current Workfile:

Click Yes button to save the changes.    If the current file has not been named File 
Defender opens a the File Save As dialog box so you can name the file.

Click No button to discard the changes.

----------------------------------------------
See also
Opening,and Saving Workfiles



Open command (File menu)

Use this command to open an existing File Defender Workfiles

File Defender displays the File Open dialog box which lets you select a File Defender 
Workfile.

Note: If the current Workfile has not been saved File Defender prompts you if you want to 
save the current WorkFile.

----------------------------------------------
See also
Opening,and Saving Workfiles



Save command (File menu)

Use this command to save the active File Defender Workfile with its current name, and 
location. 

Note: When you save a WorkFile for the first time(if filename is NONAME00.DAT), File 
Defender displays the Save As dialog box so you can name your WorkFile. If you use 
an existing file name to name the file, File Defender asks if you want to overwrite the 
existing file.

Note: If you want to change the name, location, or format of an existing document before 
you save it, choose the Save As command.    

----------------------------------------------
See also
Opening and Saving Workfiles



Save As command (File menu)

Use this command to save and name the currently selected group of files as a File Defender 
Workfiles

Note: To save a group of files with its existing name and settings, use the Save command 
from the File menu.

File Defender displays the File Save As dialog box which lets you create a File Defender 
Workfile.

----------------------------------------------
See also
Opening and Saving Workfiles



Select Files...command (File menu)

Use this command to select files in the File Defender File Window.
 
File Defender displays the Select Files status box which lets you specify the files you want to 
select or deselect.

----------------------------------------------
See Also
Building Workfiles 



Exit command (File menu)

Use this command to quit File Defender. 

Note: Make sure the Save Settings On Exit command on the Options menu has a check 
mark next to it if you want to retain the current View and Options command 
settings.



Run All command (FDefend menu)

Use this command to run FDefend using the currently selected files as the File Defender 
Workfile.

Note: If File Defender is unable to run FDefend (FDEFEND.EXE)    then an Application Error 
message box is displayed.

----------------------------------------------
See also
Running FDefend Using Menu Commands



Run File command (FDefend menu)

Use this command to run FDefend using an existing file as the File Defender Workfile.

File Defender displays the File Run dialog box which lets you select Workfile to run.

Note: If File Defender is unable to run FDefend (FDEFEND.EXE)    then an Application Error 
message box is displayed.

----------------------------------------------
See also
Running FDefend Using Menu Commands



Log... command (FDefend menu)

Use this command to open the File Defender Log using the Windows program Notepad.

Note: In order to use this command, the Windows program NOTEPAD.EXE    must be in the 
path.    If it does not exist, another text editor or word processing program may be 
used to open the Log.

Note: If File Defender is unable to run the Windows program NOTEPAD.EXE then an 
Application Error message box is displayed.

For help using Notepad see Notepad's help system.



Errorfile... command (FDefend menu)

Use this command to open an existing File Defender Errorfile using the Windows program 
Notepad.

File Defender displays the File Open dialog box which lets you select the File Defender 
Errorfile

Note: In order to use this command, the Windows program NOTEPAD.EXE    must be in the 
path.    If it does not exist, another text editor or word processing program may be 
used to open the Errorfile.

Note: If File Defender is unable to run the Windows program NOTEPAD.EXE then an 
Application Error message box is displayed.

For help using Notepad see Notepad's help system.

----------------------------------------------
See also
Opening File Defender Errorfiles



Configure... command (FDefend menu)

Use this command to set-up FDefend's configuration, this determines how FDefend runs a 
Workfile. 

File Defender displays the FDefend Configuration dialog box which lets you modify FDefend's
configuration.

----------------------------------------------
See also
Building File Defender Workfiles
Opening, and Saving Workfiles
Configuring FDefend



Tree and Directory command (View menu)

Use this command to display both the directory tree and the contents of the current 
directory. 

----------------------------------------------
See also
Changing Views



Tree Only command (View menu)

Use this command to display only the directory tree; the contents of the current directory 
are not displayed. 

----------------------------------------------
See also
Changing Views



Directory Only command (View menu)

Use this command to display only the contents of the current directory; the directory tree is 
not displayed. 

----------------------------------------------
See also
Changing Views



File Details Command (View menu)

Use this command to display specific file information in the directory window. 

File Defender displays the File Details dialog box which lets you select the file details to be 
displayed in the file window.

----------------------------------------------
See also
Displaying File Properties



Name command (Sort By cascading menu)

Use this command to sort files alphabetically by name. 

----------------------------------------------
See also
Sorting Files 



Type command (Sort By cascading menu)

Use this command to sort files alphabetically by extension. 

----------------------------------------------
See also
Sorting Files 



Size command (Sort By cascading menu)

Use this command to sort files from smallest to largest 

----------------------------------------------
See also
Sorting Files 



Date command (Sort By cascading menu)

Use this command to sort files from youngest to oldest using last modification date. 

----------------------------------------------
See also
Sorting Files 



By File Type command (View menu)

Use this command to display groups of files that you specify. 

File Defender displays the By File Type dialog box which allows you to select the groups of 
files to be displayed.

----------------------------------------------
See also
Displaying a Group of Files



Lower Case command (Options menu)

Use this command to display all files and directories in lower case.

----------------------------------------------
See also
Changing Case



Save Settings on Exit command (Options menu)

Use this command to save View and Option menu settings as when you last quit File 
Defender. 



Refresh command (Window menu)

Use this command to update the entire File Defender Main Window.

----------------------------------------------
See also
Updating the Directory Window 



Index command (Help menu)

Use this command to display the opening screen of Help. From the opening screen, you can 
jump to step-by-step instructions for using File Defender and various types of reference 
information.

Once you open Help, you can click the Contents button on the left in the Help window 
whenever you want to return to the opening screen.



Keyboard command (Help menu)

Use this command to find help on how to use the keyboard with File Defender 



Commands command (Help menu)

Use this command to see an index of all the File Defender commands.



Procedures command (Help menu)

Use this command to see an index of all the File Defender procedures.



Using Help command (Help menu)

Use this command to find help on how to use Help.



Register Command (Help menu)

Use this command to register your copy of File Defender.

Note: Once you have registered your copy of File Defender you can remove the registration 
program FDREG.EXE from your system.



About File Defender Command (Help menu)

Use this command to display product name, copyright, credits, program version, the 
registration name of your copy of File Defender, and some useful system statistics.





The Index contains a list of all Help topics available for File Defender. For information on how 
to use Help, press F1 or choose Using Help command from the Help menu.



The File Defender Workfile Manager (FD.EXE) is a utility program that provides all of the 
commands which allow build, edit, open, save File Defender Workfiles and File Defender 
Errorfiles, as well as provide a launching platform for the companion program FDefend.



FDefend (FDEFEND.EXE) is the utility program that performs all of the protection functions 
(checksums, etc.) on File Defender Workfiles, as well as create File Defender Errorfiles.



The FD Scheduler (FDSCHED.EXE) is a versatile scheduling utility used to launch FDefend at 
a specified time completely unattended.    The schedulers versatility allows it to be used with
any Windows program or non-Windows application and can be configured to run programs 
by certain intervals, on certain days or one time only. For help using FD Scheduler see FD 
Scheduler's help
system (FDSCHED.HLP)



FDefend Configuration
These settings determine the behavior of FDefend when it is running. 



Workfile
A File Defender Workfile is a collection of files that have been selected and saved using the 
File Defender program.

File Defender Workfiles are saved with the extension DAT.



FDefend errors
FDefend errors can be one of five types.

Checksum The file's contents have changed.
Size The file's size has changed.
Date/Time The file's date/time has changed.
Attribute The file's attribute has changed.
Not Found The file was not found or was in use by Windows.



Errorfile
A File Defender Errorfiles are created when errors are found by FDefend. File Defender 
Errorfiles are saved with the extension 'ERR' in the directory of the Workfile.



Log
The File Defender Log (DEFENDER.LOG) is the file that is appended each time FDefend is ran.
This text file reports the results of FDefend. This file is found in the File Defender working 
directory.



wildcard
Wildcard characters are used to represent represents one or more characters.    The wildcard 
characters are:

? (question mark)    - used to represent any single character
* (asterisk) - used to represent any character or group of characters

 that might    match that position in filenames.

For example:

*.* Any filename with any extension.
*.BMP Any filename with extension '.BMP'.
*.??T Any filename with a 3 letter extension ending with T
TE*.* Any filename starting with the letters TE
T?MP.* Any 4 letter filename starting with T and ending with MP with any extension.



Chkdsk
MS-DOS command that reports logical errors found in the file allocation table and file 
system. If errors exist on the disk, chkdsk alerts you with a message.    If the /f switch is 
included chkdsk fixes errors on the disk. Refer to the MS-DOS User's Guide and Reference 
for more information.



The name that identifies a disk



drive icon
An Icon in a directory window in File Defender that represents a disk drive in your system.



The size in bytes of a file.



The date the file was last changed according to the system clock.



The time the file was last changed according to the system clock.



One of the four file attributes which determine whether a file is read-only, hidden, archive, or
system.(See also hidden file)



name
To display all files with similar names or file types use wildcards in the name box.



WIN.INI file
An initialization file that is created when you install Windows.    This file contains information 
about how Windows looks and behaves.    Windows applications use this file to obtain 
information to configure themselves.



file type
Use these check boxes to specify which types of files to display.

Select To Display
--------------------------------------------------------------------------
Programs All files ending with EXE, BAT, PIF or COM.
Documents All files with associations.
Other All others



show hidden/system files
Show files with hidden or system attributes.



header bar
Bar above directory window that displays drives and volume id of current drive.



Directory Tree
A hierarchical representation of the contents of a drive. 



Context Sensitive Topics
This Help system includes topics that you can call directly from File Defender. To get context-
sensitive help from File Defender, press Shift+F1 and click on any element of the File 
Defender Directory Window. You can also highlight any File Defender menu command 
using the keyboard and press F1 to get help on the command. 



A file's checksum is the numerical total of all the bytes of the file code which is used to 
compare the contents from one version to another. For example, a simple batch file 
SIMPLE.BAT may contain the following text: ECHO HELLO
which to the computer looks like: 69 67 72 79 32 72 69 76 76 79
and the sum of these is: 691
This is the file's checksum.If any of the characters in the file were to change, the checksum 
would change, indicating the file's contents has been modified. This is a simple, compact 
way of storing the status of the file's contents. 



Foreground (normal) mode is when a program is the active window and it recieves the user's
input. (See also background mode)



Background mode is when a program is running but is not the window that is currently 
selected.    An application in background mode cannot receive user input. A unhidden 
background application may be brought to the foreground using the mouse or keyboard 
commands while a hidden background application may not.(See also foreground mode)



A hidden file is a file that is not intended to be viewed in a directory listing.



An executable file or program file are files that    include the extensions:
.COM,.EXE, .PIF, .DLL, .VOR, .OVL, .DRV, .BIN, .INI, .SYS.



The boot sector on a diskette or fixed disk contains the code that loads DOS into memory.



An icon is a graphical representation of any element in Windows.    Icons are used to 
represent applications, drives, directories, files, etc.



The File Defender Main Window

In the File Defender Workfile Manager, your files are displayed in the File Defender Main 
Window which is split. The left half displays the directory tree, and the right half displays 
the contents of the current directory. When you select a different directory in the directory 
tree, the contents of that directory are displayed in the right half of the window. 

File Defender Main Window Caption

Displays the current    directory and name of the File Defender Workfile

File Defender Directory Tree Window

In the directory tree window, each directory has an icon next to it, indicating presence of 
subdirectories. 

File Defender File Window

In the file window, the filename of the current directory are displayed. Each filename has an 
icon next to it, indicating what type of file it is. 

File Defender Menu Bar

The File Defender Menu bar displays all the commands available to File Defender.
For more information choose one of the following menu commands:

File    FDefend    View    Options    Window    Help

File Defender Header Bar

At the top of the main window is the header bar    where icons for each drive you currently 
have access to are displayed. These icons are called drive icons . Different icons represent 
the different types of drives on your computer: hard disk drives, floppy disk drives, and 
network drives. (RAM drives, CD-ROMs and floppy disk drives are not supported by File 
Defender). You can change to a different drive by selecting its drive icon. The header bar 
also displays the volume label of the drive.

File Defender Status Bar

At the bottom of the main window    is the status bar where information on the number of 
selected files are displayed.    The box on the left hand side displays the total number of files 
selected in all directories, the box on the right hand side displays the total number of files 
selected in the current directory.    



File Open Dialog Box

This dialog box appears when you click the Open... command Open Errorfile... command 
from the File menu of the File Defender Main Window. 

Use this dialog box to find the filename you want to open.

Directory

This text box    displays the current default or currently-selected directory. This text changes 
automatically when you select from the Directory list boxes.

Filename

Type the filename and press Enter or, select a file from the Files list box, or, type a new 
wildcard file specification and press Enter to see only files matching that wildcard. 

When you click OK, the currently displayed selected filename is opened and its files are 
(highlighted) in the File Defender File Window.

Files List Box

This list shows the names of files in the current directory, in alphabetical order.

You can type the first character of a filename to quickly scroll to that part of the list or, use 
the scroll bar to look through this list. You can double-click a filename to select it and 
automatically confirm the selection.

Directories List Box

You can type the first character of a directory name to quickly scroll to that part of the list or,
use the scroll bar to look through this list. When you click a directory, its files are shown in 
the Files List Box.
You can type a drive letter or, click the prompt button and use the scroll bar to look through 
this list. When you select a drive, its directories will be listed in the Directory List Box.

OK Button

Click this button, or double-click a filename, or press Enter to confirm your selection of the 
filename and close the dialog box.. 

Cancel Button

Exits the File Open dialog box without selecting a file.

Help Button

Displays this screen.



File Run Dialog Box

This dialog box appears when you click the Run File... command from the FDefend menu 
of the File Defender Main Window. 

Use this dialog box to find the filename of the File Defender Workfile you want to FDefend to 
run.

Directory

This text box    displays the current default or currently-selected directory. This text changes 
automatically when you select from the Directory list boxes.

Filename

Type the filename and press Enter or, select a file from the Files list box, or, type a new 
wildcard file specification and press Enter to see only files matching that wildcard. The 
default wildcard is *.DAT.

When you click OK, the currently displayed selected filename is opened and its files are 
(highlighted) in the File Defender File Window.

Files List Box

This list shows the names of files in the current directory, in alphabetical order.

You can type the first character of a filename to quickly scroll to that part of the list or, use 
the scroll bar to look through this list. You can double-click a filename to select it and 
automatically confirm the selection.

Directories List Box

You can type the first character of a directory name to quickly scroll to that part of the list or,
use the scroll bar to look through this list. When you click a directory, its files are shown in 
the Files List Box.
You can type a drive letter and use the scroll bar to look through this list. When you select a 
drive, its directories will be listed in the Directories List Box.

OK Button

Click this button, or double-click a filename, or press Enter to confirm your selection of the 
file you want to run and close the dialog box.. 

Cancel Button

Exits the File Run dialog box without selecting a file.

Help Button

Displays this screen.



File Save As Dialog Box

This dialog box appears when you click either the File Save As... command from the File 
menu of the File Defender Main Window or when you save a new file. 

Use this dialog box to find the filename you want to save.

Directory

This text box    displays the current default or currently-selected directory. This text changes 
automatically when you select from the Directories List Box.

Filename

Type the filename and press Enter.  The default wildcard is *.DAT

When you click OK, the currently File Defender Workfile is saved using the currently selected
displayed filename.

Directories List Box

You can type the first character of a directory name to quickly scroll to that part of the list or,
use the scroll bar to look through this list. When you select a drive, its directories will be 
listed in the Directories List Box.

OK Button

Click this button, or double-click a filename, or press Enter to confirm your selection of the 
filename and close the dialog box.. 

Cancel Button

Exits the File Save As dialog box without saving the file.

Help Button

Displays this screen.



By File Type Dialog Box

This dialog box appears when you click the By File Type... command from the View menu 
of the File Defender Main Window. 

Use this dialog box to view only certain groups of files in the File Defender File Window. 
You can specify a filter using wildcard file specification and/or file attributes. 

Filename    Display Box

Enter one or more wildcard file specifications, separated by semicolons and only those files 
matching the wildcard specifications are shown.

File Type Group

Select a check box:

                                        Programs: Only files having an extension of .EXE, .COM, .PIF and
.BAT are displayed.

                                  Documents: Only files having an association are displayed.
                                                      Other: All other file specifications are shown under this option --

there is no filtering of filename or extension.
Show Hidden/System: Those files with the hidden or system attribute are displayed.

OK Button

Click this button, or press Enter to confirm your selections and close the dialog box.. 

Cancel Button

Exits the By File Type dialog box without changing options.

Help Button

Displays this screen.



File Details Dialog Box

This dialog box appears when you click the File Details... command from the View menu of
the File Defender Main Window. 

Use it to specify the file details to be shown in the File Defender File Window. 

Details

Check the check boxes containing the attributes you want displayed in the directory window.

                                                                                    Icon: Displays the file's icon.
                                                                                    Size: Displays the file size in bytes.
Last Modification Date: Displays the file's last modification date
Last Modification Time: Displays the file's last modification time
                                                                  Attribute:Displays the file's attribute

OK Button

Click this button, or press Enter to confirm your selections and close the dialog box.

Cancel Button

Exits the File Details dialog box without changing options.

Help Button

Displays this screen.



Select Files Status Box

This dialog box appears when you click the Select Files... command from the File menu of 
the File Defender Main Window. , it lets you quickly select or deselect files in the File 
Defender File Window by using wildcards.

Directory

Display the current directory that you are selecting or deselecting files from.

Files

Enter one or more wildcard file specifications, separated by semi-colons. For instance, 
entering *.BAT;*.COM selects all files with either '.COM' or '.BAT' extensions

Include Subdirectories Checkbox

Check this box if you want to select or deselect files in subdirectories of the current 
directory.

Select Button

Click this button to select files, File Defender will display the number of files found and the 
number of files selected.

Deselect Button

Click this button to deselect files, File Defender will display the number of files found and the
number of files deselected.

Close(Stop) Button

Exits the Select Files status box.

Note: If File Defender is still running then pressing this button will stop File Defender from 
selecting or deselecting files. To close the Select Files status box press this button 
again. 

Help Button

Displays this screen.

Tip: Files not included in the wildcard specification are still displayed, but not selected. If 
you want to see only certain types of files, choose the By Type command from the 
View menu. For help with selecting files, see Building Workfiles.



FDefend Configuration Dialog Box

This dialog box appears when you click the Configuration... command from the FDefend 
menu of the File Defender Main Window. 

Use this dialog box to configure how FDefend runs a Workfile.

The FDefend Configuration dialog box has the following options: 

Options

checksum: Check this box if you want FDefend to perform a checksum operation on each 
file in the File Defender Workfile. The checksum total is then compared with the previous 
value to determine if the file's contents have changed.    FDefend reports an error if there is a
difference between the previous and current checksum values. These errors are recorded in 
a File Defender Errorfile. 

Note: The first time FDefend performs a checksum operation on a Workfile, the value of the 
checksum is not compared with the previous value since it has not been computed, 
therefore no checksum errors are reported.    This value of the checksum 
automatically replaces the previous value (-1 by default).    Therefore it is strongly 
advised that you run FDefend as soon as possible after selecting your files.    Also, see
replace errors option for more information.

Check file information: Check this box if you want FDefend to compare the attribute, 
size, and date/time information of each file in the File Defender Workfile with its previous 
value.    If there is a difference between the previous and current values of the file 
information, these errors are recorded in the File Defender Errorfile

Replace Errors:    If a difference is found between the previous value and the current value 
in the File Defender Workfile, the current value replaces the previous value.

Note: If the File Defender Workfile contains a filename that is not valid, checking this option
will cause FDefend to remove this file from the Workfile.

Note: If you are running FDefend periodically, checking this option will cause FDefend to 
only detect errors for the first time. 

Errorfile Options

save Errorfile as a new file:      Check this box if you want FDefend to save File Defender 
Errorfiles with a unique filename. If this box is not checked then the Errorfile is saved with 
the Workfile name and the extension 'ERR'.    If this box is checked then FDefend saves the 
Errorfile with a unique name in the form 'NAMEnnn.ERR' where nnn ranges between '000' 
and '999', (starting at '000').

save Errorfile as a hidden file: Check this box if you want FDefend to save the File 
Defender Errorfile with the hidden attribute.

FDefend Status Options

show status: Select this button if you want FDefend to display the FDefend Status box 
while running. If this option is selected then FDefend will also display messages reporting 
the number of errors found and the filename of the File Defender Errorfile.



hide status: Select this button if you want FDefend to hide the FDefend Status box while 
running. If this option is selected then FDefend will run completely undetected by the user.

Important: If the hide status option is selected then you will not be able to stop the 
program from running.    To end the program you must exit Windows. (See also
Exiting Windows while FDefend is running)

OK Button

Click this button, or press Enter to confirm your selections and close the dialog box.

Cancel Button

Exits the FDefend Configuration dialog box without changing options.

Help Button

Displays this screen.



FDefend Status Box

This status box appears when you click the Show FDefend Status... option from the 
FDefend Configuration Dialog Box. and FDefend is running.

The FDefend Status box displays the following information:

FDefend Status Box Caption

Displays the name of the current File Defender Workfile.

Files

Displays the name of the current file in the File Defender Workfile being analyzed.

Files Checked

Displays the number of files that have been checked.

Files Selected

Displays the number of files selected in the Workfile.

Errors Found

Displays the total number of errors found.

Cancel Button

Closes FDefend. Any errors that are found are saved.



Application Error Message Box

The Application Error message box is displayed when there is an error running an 
application.
The message box displays then application name plus an error code.

Error Code

The error code value may be one of the following: 

Value Meaning

    0 System was out of memory, executable file was corrupt, or relocations were invalid. 
    2 File was not found. 
    3 Path was not found. 
    5 Attempt was made to dynamically link to a task, or there was a sharing or network-

protection error. 
    6 Library required separate data segments for each task. 
    8 There was insufficient memory to start the application. 
10 Windows version was incorrect. 
11 Executable file was invalid. Either it was not a Windows application or there was an 

error in the .EXE image. 
12 Application was designed for a different operating system. 
13 Application was designed for MS-DOS 4.0. 
14 Type of executable file was unknown. 
15 Attempt was made to load a real-mode application (developed for an earlier version 

of    Windows). 
16 Attempt was made to load a second instance of an executable file containing multiple

data segments that were not marked read-only. 
19 Attempt was made to load a compressed executable file. The file must be 

decompressed before it can be loaded. 
20 Dynamic-link library (DLL) file was invalid. One of the DLLs required to run this 

application was corrupt. 
21 Application requires Microsoft Windows 32-bit extensions. 


